Issue in the "New Project" Wizard

Sep 11, 2007 at 3:14 AM

Background

I'm trying to create a "Pure WPF CAB" example which means the shell form as well as the internal views are based on WPF instead of WinForm.

Issue Description

  1. I downloaded the 1.01 version of this WPF factory.
  2. After installation, a "Smart Client Development WPF" node is added to the "Guidance Packages" node of Visual Studio "New Project" dialog.
  3. In this dialog,
    1. I select the "Smart Client Development WPF" node
    2. select the "Smart Client Application" template
    3. specify the project name and location
  4. Then I enters the "Creates a new WPF Smart Client Solution" page, in which I need to provide the CAB & Enterprise Library DLL's location and the Root namespace.
The issue exists in the "Location of CAB DLLs" edit box. The wizard doesn't acknowledge the CAB DLLs location that I specify by inputing the full path string or by using the "Browse for Folder" function. The edit box keeps empty and a red warning icon shows "The directory doesn't appear to contain the CAB DLLs". And the "Finish" button is disabled and gray.

Some information of my system:

  • OS: Windows XP English version, SP2 with all latest system patches applied.
  • IDE: VS 2005 SP1 with CAB, GAX, GAT, SCSF (2007 version that can create WPF views) installed to the default path.
  • .NET Framework version: 3.0
  • The directory of SCSF: "c:\Program Files\Microsoft Smart Client Factory". And the CAB DLLs location expected by the SCSF WPF Factory should be "c:\Program Files\Microsoft Smart Client Factory\Lib".

Does anybody happen to encounter the similar issue and could kindly let me know the solution?
Israeli, would you please help to have a look at this issue?

Thanks a lot!

Best regards,
XGardener
Nov 7, 2007 at 10:04 AM
Exact same problem here. Did anybody find a way to get around this in the meantime?

I was trying to figure out which assembly actually drives that dialog so I could go to Reflector an see what is behind the scenes but I cannot find it.

Any help or input would be greatly appreciated.

Best regards

Arne

Jan 25, 2008 at 5:43 AM
Edited Jan 25, 2008 at 5:50 AM
Hi guys, if you set this directory to "C:\Program Files\SCSFWPF" or wherever you installed the SCSFWPF then it seems to work.

Cheers

Justin